XML

XML (Extensible Markup Language) usage in protocols and XML-based formats

XML RFCs (112)

Display RFCs as
  • RFC 9457: Problem Details for HTTP APIs

    Proposed Standard
  • RFC 9321: Signature Validation Token

    Informational
  • RFC 9231: Additional XML Security Uniform Resource Identifiers (URIs)

    Proposed Standard
  • RFC 8846: An XML Schema for the Controlling Multiple Streams for Telepresence (CLUE) Data Model

    Proposed Standard
  • RFC 8794: Extensible Binary Meta Language

    Proposed Standard
  • RFC 8759: RTP Payload for Timed Text Markup Language (TTML)

    Proposed Standard
  • RFC 8341: STD 91: Network Configuration Access Control Model

    Internet Standard
  • RFC 7950: The YANG 1.1 Data Modeling Language

    Proposed Standard
  • RFC 7940: Representing Label Generation Rulesets Using XML

    Proposed Standard
  • RFC 7807: Problem Details for HTTP APIs

    Proposed Standard

      Obsoleted by RFC 9457

  • RFC 7749: The "xml2rfc" Version 2 Vocabulary

    Informational

      Obsoleted by RFC 7991

  • RFC 7745: XML Schemas for Reverse DNS Management

    Informational
  • RFC 7351: A Media Type for XML Patch Operations

    Informational
  • RFC 7328: Writing I-Ds and RFCs Using Pandoc and a Bit of XML

    Informational
  • RFC 7303: XML Media Types

    Proposed Standard
  • RFC 7061: eXtensible Access Control Markup Language (XACML) XML Media Type

    Informational
  • RFC 6931: Additional XML Security Uniform Resource Identifiers (URIs)

    Proposed Standard

      Obsoleted by RFC 9231

  • RFC 6685: Expert Review for Incident Object Description Exchange Format (IODEF) Extensions in IANA XML Registry

    Proposed Standard

      Obsoleted by RFC 7970

  • RFC 6536: Network Configuration Protocol (NETCONF) Access Control Model

    Proposed Standard

      Obsoleted by RFC 8341

  • RFC 6470: Network Configuration Protocol (NETCONF) Base Notifications

    Proposed Standard
  • RFC 6351: xCard: vCard XML Representation

    Proposed Standard
  • RFC 6321: xCal: The XML Format for iCalendar

    Proposed Standard
  • RFC 6283: Extensible Markup Language Evidence Record Syntax (XMLERS)

    Proposed Standard
  • RFC 6241: Network Configuration Protocol (NETCONF)

    Proposed Standard
  • RFC 6207: The Media Types application/mods+xml, application/mads+xml, application/mets+xml, application/marcxml+xml, and application/sru+xml

    Informational
  • RFC 6120: Extensible Messaging and Presence Protocol (XMPP): Core

    Proposed Standard
  • RFC 6121: Extensible Messaging and Presence Protocol (XMPP): Instant Messaging and Presence

    Proposed Standard
  • RFC 6122: Extensible Messaging and Presence Protocol (XMPP): Address Format

    Proposed Standard

      Obsoleted by RFC 7622

  • RFC 6137: The Network Trouble Ticket Data Model (NTTDM)

    Experimental
  • RFC 6129: The 'application/tei+xml' Media Type

    Informational
  • RFC 6087: Guidelines for Authors and Reviewers of YANG Data Model Documents

    Informational

      Obsoleted by RFC 8407

  • RFC 6020: YANG - A Data Modeling Language for the Network Configuration Protocol (NETCONF)

    Proposed Standard
  • RFC 6022: YANG Module for NETCONF Monitoring

    Proposed Standard
  • RFC 5935: Expressing SNMP SMI Datatypes in XML Schema Definition Language

    Proposed Standard
  • Proposed Standard
  • RFC 5874: An Extensible Markup Language (XML) Document Format for Indicating a Change in XML Configuration Access Protocol (XCAP) Resources

    Proposed Standard
  • RFC 5875: An Extensible Markup Language (XML) Configuration Access Protocol (XCAP) Diff Event Package

    Proposed Standard
  • RFC 5910: Domain Name System (DNS) Security Extensions Mapping for the Extensible Provisioning Protocol (EPP)

    Proposed Standard
  • RFC 5784: Sieve Email Filtering: Sieves and Display Directives in XML

    Proposed Standard
  • RFC 5731: STD 69: Extensible Provisioning Protocol (EPP) Domain Name Mapping

    Internet Standard
  • RFC 5732: STD 69: Extensible Provisioning Protocol (EPP) Host Mapping

    Internet Standard
  • RFC 5733: STD 69: Extensible Provisioning Protocol (EPP) Contact Mapping

    Internet Standard
  • RFC 5734: STD 69: Extensible Provisioning Protocol (EPP) Transport over TCP

    Internet Standard
  • RFC 5388: Information Model and XML Data Model for Traceroute Measurements

    Proposed Standard
  • Proposed Standard
  • RFC 5364: Extensible Markup Language (XML) Format Extension for Representing Copy Control Attributes in Resource Lists

    Proposed Standard
  • RFC 5261: An Extensible Markup Language (XML) Patch Operations Framework Utilizing XML Path Language (XPath) Selectors

    Proposed Standard
  • RFC 5277: NETCONF Event Notifications

    Proposed Standard
  • RFC 5168: XML Schema for Media Control

    Informational
  • RFC 5107: DHCP Server Identifier Override Suboption

    Proposed Standard
  • RFC 5025: Presence Authorization Rules

    Proposed Standard
  • RFC 4991: A Common Schema for Internet Registry Information Service Transfer Protocols

    Proposed Standard
  • RFC 4992: XML Pipelining with Chunks for the Internet Registry Information Service

    Proposed Standard
  • RFC 4910: Robust XML Encoding Rules (RXER) for Abstract Syntax Notation One (ASN.1)

    Experimental
  • RFC 4911: Encoding Instructions for the Robust XML Encoding Rules (RXER)

    Experimental
  • RFC 4912: Abstract Syntax Notation X (ASN.X)

    Experimental
  • RFC 4913: Abstract Syntax Notation X (ASN.X) Representation of Encoding Instructions for the Generic String Encoding Rules (GSER)

    Experimental
  • RFC 4914: Abstract Syntax Notation X (ASN.X) Representation of Encoding Instructions for the XML Encoding Rules (XER)

    Experimental
  • RFC 4825: The Extensible Markup Language (XML) Configuration Access Protocol (XCAP)

    Proposed Standard
  • RFC 4826: Extensible Markup Language (XML) Formats for Representing Resource Lists

    Proposed Standard
  • RFC 4827: An Extensible Markup Language (XML) Configuration Access Protocol (XCAP) Usage for Manipulating Presence Document Contents

    Proposed Standard
  • RFC 4765: The Intrusion Detection Message Exchange Format (IDMEF)

    Experimental
  • RFC 4741: NETCONF Configuration Protocol

    Proposed Standard

      Obsoleted by RFC 6241

  • RFC 4743: Using NETCONF over the Simple Object Access Protocol (SOAP)

    Historic
  • RFC 4744: Using the NETCONF Protocol over the Blocks Extensible Exchange Protocol (BEEP)

    Historic
  • RFC 4661: An Extensible Markup Language (XML)-Based Format for Event Notification Filtering

    Proposed Standard
  • RFC 4536: The application/smil and application/smil+xml Media Types

    Informational
  • RFC 4374: The application/xv+xml Media Type

    Informational
  • RFC 4227: Using the Simple Object Access Protocol (SOAP) in Blocks Extensible Exchange Protocol (BEEP)

    Proposed Standard
  • RFC 4287: The Atom Syndication Format

    Proposed Standard
  • RFC 4267: The W3C Speech Interface Framework Media Types: application/voicexml+xml, application/ssml+xml, application/srgs, application/srgs+xml, application/ccxml+xml, and application/pls+xml

    Informational
  • RFC 4194: The S Hexdump Format

    Proposed Standard
  • RFC 4153: XML Voucher: Generic Voucher Language

    Informational
  • RFC 4050: Using the Elliptic Curve Signature Algorithm (ECDSA) for XML Digital Signatures

    Informational
  • RFC 4051: Additional XML Security Uniform Resource Identifiers (URIs)

    Proposed Standard

      Obsoleted by RFC 6931

  • RFC 3994: Indication of Message Composition for Instant Messaging

    Proposed Standard
  • RFC 3910: The SPIRITS (Services in PSTN requesting Internet Services) Protocol

    Proposed Standard
  • RFC 3920: Extensible Messaging and Presence Protocol (XMPP): Core

    Proposed Standard

      Obsoleted by RFC 6120

  • RFC 3921: Extensible Messaging and Presence Protocol (XMPP): Instant Messaging and Presence

    Proposed Standard

      Obsoleted by RFC 6121

  • RFC 3922: Mapping the Extensible Messaging and Presence Protocol (XMPP) to Common Presence and Instant Messaging (CPIM)

    Proposed Standard
  • RFC 3923: End-to-End Signing and Object Encryption for the Extensible Messaging and Presence Protocol (XMPP)

    Proposed Standard
  • RFC 3881: Security Audit and Access Accountability Message XML Data Definitions for Healthcare Applications

    Informational
  • RFC 3902: The "application/soap+xml" media type

    Informational
  • RFC 3870: application/rdf+xml Media Type Registration

    Informational
  • RFC 3858: An Extensible Markup Language (XML) Based Format for Watcher Information

    Proposed Standard
  • RFC 3863: Presence Information Data Format (PIDF)

    Proposed Standard
  • RFC 3823: MIME Media Type for the Systems Biology Markup Language (SBML)

    Informational
  • RFC 3767: Securely Available Credentials Protocol

    Proposed Standard
  • RFC 3741: Exclusive XML Canonicalization, Version 1.0

    Informational
  • RFC 3688: BCP 81: The IETF XML Registry

    Best Current Practice
  • RFC 3653: XML-Signature XPath Filter 2.0

    Informational
  • RFC 3614: A Uniform Resource Name (URN) Namespace for the Motion Picture Experts Group (MPEG)

    Informational
  • RFC 3541: A Uniform Resource Name (URN) Namespace for the Web3D Consortium (Web3D)

    Informational
  • RFC 3529: Using Extensible Markup Language-Remote Procedure Calling (XML-RPC) in Blocks Extensible Exchange Protocol (BEEP)

    Experimental
  • RFC 3504: Internet Open Trading Protocol (IOTP) Version 1, Errata

    Informational
  • RFC 3505: Electronic Commerce Modeling Language (ECML): Version 2 Requirements

    Informational
  • RFC 3470: BCP 70: Guidelines for the Use of Extensible Markup Language (XML) within IETF Protocols

    Best Current Practice
  • RFC 3288: Using the Simple Object Access Protocol (SOAP) in Blocks Extensible Exchange Protocol (BEEP)

    Proposed Standard

      Obsoleted by RFC 4227

  • RFC 3275: (Extensible Markup Language) XML-Signature Syntax and Processing

    Draft Standard
  • RFC 3236: The 'application/xhtml+xml' Media Type

    Informational
  • RFC 3120: A URN Namespace for XML.org

    Informational
  • RFC 3075: XML-Signature Syntax and Processing

    Proposed Standard

      Obsoleted by RFC 3275

  • RFC 3076: Canonical XML Version 1.0

    Informational
  • RFC 3023: XML Media Types

    Proposed Standard

      Obsoleted by RFC 7303

  • RFC 3017: XML DTD for Roaming Access Phone Book

    Proposed Standard
  • RFC 2935: Internet Open Trading Protocol (IOTP) HTTP Supplement

    Proposed Standard
  • RFC 2807: XML Signature Requirements

    Informational
  • RFC 2802: Digital Signatures for the v1.0 Internet Open Trading Protocol (IOTP)

    Informational
  • RFC 2803: Digest Values for DOM (DOMHASH)

    Informational
  • RFC 2731: Encoding Dublin Core Metadata in HTML

    Informational

      Obsoleted by RFC 5791

  • RFC 2629: Writing I-Ds and RFCs using XML

    Informational

      Obsoleted by RFC 7749

  • RFC 2376: XML Media Types

    Informational

      Obsoleted by RFC 3023

Subscribe to XML

Get notified when:

  • RFC changes to status, obsoleted by, updates, updated by, or subseries.
  • New RFC added to this subject or below
  • The subject was merged into another.