Telnet

The Telnet protocol and its options

Telnet RFCs (125)

Display RFCs as
  • RFC 6270: The 'tn3270' URI Scheme

    Proposed Standard
  • RFC 5929: Channel Bindings for TLS

    Proposed Standard
  • RFC 4777: IBM's iSeries Telnet Enhancements

    Informational
  • RFC 4248: The telnet URI Scheme

    Proposed Standard
  • RFC 2941: Telnet Authentication Option

    Proposed Standard
  • RFC 2942: Telnet Authentication: Kerberos Version 5

    Proposed Standard
  • RFC 2943: TELNET Authentication Using DSA

    Proposed Standard
  • RFC 2944: Telnet Authentication: SRP

    Proposed Standard
  • RFC 2946: Telnet Data Encryption Option

    Proposed Standard
  • RFC 2947: Telnet Encryption: DES3 64 bit Cipher Feedback

    Proposed Standard
  • RFC 2948: Telnet Encryption: DES3 64 bit Output Feedback

    Proposed Standard
  • RFC 2949: Telnet Encryption: CAST-128 64 bit Output Feedback

    Proposed Standard
  • RFC 2950: Telnet Encryption: CAST-128 64 bit Cipher Feedback

    Proposed Standard
  • RFC 2951: TELNET Authentication Using KEA and SKIPJACK

    Informational
  • RFC 2952: Telnet Encryption: DES 64 bit Cipher Feedback

    Informational
  • RFC 2953: Telnet Encryption: DES 64 bit Output Feedback

    Informational
  • RFC 2877: 5250 Telnet Enhancements

    Informational

      Obsoleted by RFC 4777

  • RFC 2839: Internet Kermit Service

    Informational
  • RFC 2840: TELNET KERMIT OPTION

    Informational
  • RFC 2561: Base Definitions of Managed Objects for TN3270E Using SMIv2

    Proposed Standard
  • RFC 2562: Definitions of Protocol and Managed Objects for TN3270E Response Time Collection Using SMIv2 (TN3270E-RT-MIB)

    Proposed Standard
  • RFC 2355: TN3270 Enhancements

    Draft Standard
  • RFC 2217: Telnet Com Port Control Option

    Experimental
  • RFC 2066: TELNET CHARSET Option

    Experimental
  • RFC 1921: TNVIP Protocol

    Informational
  • RFC 1922: Chinese Character Encoding for Internet Messages

    Informational
  • RFC 1739: A Primer On Internet and TCP/IP Tools

    Informational

      Obsoleted by RFC 2151

  • RFC 1646: TN3270 Extensions for LUname and Printer Selection

    Informational
  • RFC 1647: TN3270 Enhancements

    Proposed Standard

      Obsoleted by RFC 2355

  • RFC 1571: Telnet Environment Option Interoperability Issues

    Informational
  • RFC 1572: Telnet Environment Option

    Proposed Standard
  • RFC 1576: TN3270 Current Practices

    Informational
  • RFC 1416: Telnet Authentication Option

    Experimental

      Obsoleted by RFC 2941

  • RFC 1408: Telnet Environment Option

    Historic
  • RFC 1409: Telnet Authentication Option

    Experimental

      Obsoleted by RFC 1416

  • RFC 1411: Telnet Authentication: Kerberos Version 4

    Experimental
  • RFC 1412: Telnet Authentication: SPX

    Experimental
  • RFC 1372: Telnet Remote Flow Control Option

    Proposed Standard
  • RFC 1205: 5250 Telnet interface

    Informational
  • RFC 1184: Telnet Linemode Option

    Draft Standard
  • RFC 1143: The Q Method of Implementing TELNET Option Negotiation

    Experimental
  • RFC 1116: Telnet Linemode option

    Proposed Standard

      Obsoleted by RFC 1184

  • RFC 1096: Telnet X display location option

    Proposed Standard
  • RFC 1091: Telnet terminal-type option

    Proposed Standard
  • RFC 1079: Telnet terminal speed option

    Proposed Standard
  • RFC 1080: Telnet remote flow control option

    Unknown

      Obsoleted by RFC 1372

  • RFC 1073: Telnet window size option

    Proposed Standard
  • RFC 1053: Telnet X.3 PAD option

    Historic
  • RFC 1043: Telnet Data Entry Terminal option: DODIIS implementation

    Proposed Standard
  • RFC 1041: Telnet 3270 regime option

    Historic
  • RFC 946: Telnet terminal location number option

    Proposed Standard
  • RFC 930: Telnet terminal type option

    Unknown

      Obsoleted by RFC 1091

  • RFC 933: Output marking Telnet option

    Proposed Standard
  • RFC 927: TACACS user identification Telnet option

    Proposed Standard
  • RFC 884: Telnet terminal type option

    Unknown

      Obsoleted by RFC 930

  • RFC 885: Telnet end of record option

    Proposed Standard
  • RFC 854: STD 8: Telnet Protocol Specification

    Internet Standard
  • RFC 855: STD 8: Telnet Option Specifications

    Internet Standard
  • RFC 856: STD 27: Telnet Binary Transmission

    Internet Standard
  • RFC 857: STD 28: Telnet Echo Option

    Internet Standard
  • RFC 858: STD 29: Telnet Suppress Go Ahead Option

    Internet Standard
  • RFC 859: STD 30: Telnet Status Option

    Internet Standard
  • RFC 860: STD 31: Telnet Timing Mark Option

    Internet Standard
  • RFC 861: STD 32: Telnet Extended Options: List Option

    Internet Standard
  • RFC 847: Summary of Smallberg surveys

    Unknown
  • RFC 818: Remote User Telnet service

    Historic
  • RFC 779: Telnet send-location option

    Proposed Standard
  • RFC 782: Virtual Terminal management model

    Unknown
  • RFC 764: Telnet Protocol specification

    Unknown

      Obsoleted by RFC 854

  • RFC 749: Telnet SUPDUP-Output option

    Proposed Standard
  • RFC 735: Revised Telnet byte macro option

    Proposed Standard
  • RFC 736: Telnet SUPDUP option

    Proposed Standard
  • RFC 732: Telnet Data Entry Terminal option

    Unknown
  • RFC 731: Telnet Data Entry Terminal option

    Unknown

      Obsoleted by RFC 732

  • RFC 729: Telnet byte macro option

    Unknown

      Obsoleted by RFC 735

  • RFC 727: Telnet logout option

    Proposed Standard
  • RFC 728: Minor pitfall in the Telnet Protocol

    Unknown
  • RFC 726: Remote Controlled Transmission and Echoing Telnet option

    Proposed Standard
  • RFC 698: Telnet extended ASCII option

    Proposed Standard

      Obsoleted by RFC 5198

  • RFC 703: July, 1975, survey of New-Protocol Telnet Servers

    Unknown
  • RFC 688: Tentative schedule for the new Telnet implementation for the TIP

    Unknown
  • RFC 681: Network UNIX

    Unknown
  • RFC 679: February, 1975, survey of New-Protocol Telnet servers

    Unknown
  • RFC 669: November, 1974, survey of New-Protocol Telnet servers

    Unknown
  • RFC 651: Revised Telnet status option

    Unknown

      Obsoleted by RFC 859

  • RFC 652: Telnet output carriage-return disposition option

    Historic
  • RFC 653: Telnet output horizontal tabstops option

    Historic
  • RFC 654: Telnet output horizontal tab disposition option

    Historic
  • RFC 655: Telnet output formfeed disposition option

    Historic
  • RFC 656: Telnet output vertical tabstops option

    Historic
  • RFC 657: Telnet output vertical tab disposition option

    Historic
  • RFC 658: Telnet output linefeed disposition

    Historic
  • RFC 659: Announcing additional Telnet options

    Unknown
  • RFC 702: September, 1974, survey of New-Protocol Telnet servers

    Unknown
  • RFC 701: August, 1974, survey of New-Protocol Telnet servers

    Unknown
  • RFC 617: Note on socket number assignment

    Unknown
  • RFC 624: Comments on the File Transfer Protocol

    Unknown
  • RFC 595: Second thoughts in defense of the Telnet Go-Ahead

    Unknown
  • RFC 596: Second thoughts on Telnet Go-Ahead

    Unknown
  • RFC 581: Corrections to RFC 560: Remote Controlled Transmission and Echoing Telnet Option

    Unknown
  • RFC 587: Announcing New Telnet Options

    Unknown
  • RFC 593: Telnet and FTP implementation schedule change

    Unknown
  • RFC 559: Comments on The New Telnet Protocol and its Implementation

    Unknown
  • RFC 560: Remote Controlled Transmission and Echoing Telnet option

    Unknown
  • RFC 562: Modifications to the TELNET Specification

    Unknown
  • RFC 563: Comments on the RCTE Telnet option

    Unknown
  • RFC 495: Telnet Protocol specifications

    Unknown
  • RFC 513: Comments on the new Telnet specifications

    Unknown
  • RFC 452: TELNET Command at Host LL

    Unknown
  • RFC 461: Telnet Protocol meeting announcement

    Unknown
  • RFC 466: Telnet logger/server for host LL-67

    Unknown
  • RFC 435: Telnet issues

    Unknown
  • RFC 393: Comments on Telnet Protocol Changes

    Unknown
  • RFC 377: Using TSO via ARPA Network Virtual Terminal

    Unknown
  • RFC 339: MLTNET: A "Multi Telnet" Subsystem for Tenex

    Unknown
  • RFC 340: Proposed Telnet Changes

    Unknown
  • RFC 318: Telnet Protocols

    Unknown
  • RFC 328: Suggested Telnet Protocol Changes

    Unknown
  • RFC 216: Telnet Access to UCSB's On-Line System

    Unknown
  • RFC 206: A User TELNET Description of an Initial Implementation

    Unknown
  • RFC 215: NCP, ICP, and Telnet: The Terminal IMP implementation

    Unknown
  • RFC 139: Discussion of Telnet Protocol

    Unknown
  • RFC 158: Telnet Protocol: A Proposed Document

    Unknown

      Obsoleted by RFC 495

  • RFC 137: Telnet Protocol - a proposed document

    Unknown
  • RFC 97: First Cut at a Proposed Telnet Protocol

    Unknown

Subscribe to Telnet

Get notified when:

  • RFC changes to status, obsoleted by, updates, updated by, or subseries.
  • New RFC added to this subject or below
  • The subject was merged into another.