[Jprogramming] Paid programming contest: Parse J constants
Raul Miller
rauldmiller at gmail.com
Sat Oct 2 05:04:29 HKT 2010
On Fri, Oct 1, 2010 at 5:00 PM, Dan Bron <j at bron.us> wrote:
> BTW, you have a bug:
>
> pc_rdm0 '1p1'
> |value error: num5p
> | pc_rdm0'1p1'
>
> The fix:
> num5p =: numb5p NB. Rename num5p to num B 5p
> pc_rdm0 '1p1'
> (1)*(o.1)^1
>
> Similarly for num5x (I found these when I tried pc_rdm0 f. ).
Oops, sorry about that.
I should have tested in a clean session before posting.
Alternatively, I should have erased all names in base at the top of my script.
--
Raul
More information about the Programming
mailing list